Reply
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
  #1   Report Post  
Old 25-05-2007, 10:34 PM
Registered User
 
First recorded activity by GardenBanter: May 2007
Location: Stafford UK
Posts: 1
Unhappy Oase Biotec 5 Pond Filter

I changed the foam filters last year as could not get the flow through them and kept going into overflow. The same has happened again after just one year of use.Has anyone any ideas, I clean them with the fine strong hose jet
the look clean but water does not flow them very well
Please reply to my E Mail address

Reply
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules

Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help on a oase biotec screenmatic filter shrek Ponds 4 06-04-2010 02:52 PM
Control Box for Pond - Oase FM Master or Velda Remote [email protected] United Kingdom 0 02-05-2007 11:06 PM
Biotec 5.1 filter? Bill Stock Ponds 4 24-05-2006 05:30 AM
Biotec 10 David Ponds 1 13-11-2003 11:02 AM
Any Feedback on an Oase Biotec 30? Critical Popperian Ponds 1 26-05-2003 11:11 PM


All times are GMT +1. The time now is 09:58 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2004-2020 GardenBanter.co.uk.
The comments are property of their posters.
 

About Us

"It's about Gardening"

 

Copyright © 2017